There is nothing in this commit except for the changes made by nix-shell -p nixfmt-rfc-style --run "nixfmt ." If this has mucked up your open branches then sorry about that. You can probably nixfmt them to match before merging
20 lines
310 B
Nix
20 lines
310 B
Nix
{
|
|
config,
|
|
pkgs,
|
|
lib,
|
|
...
|
|
}:
|
|
let
|
|
inherit (pkgs) liminix;
|
|
inherit (lib) mkIf;
|
|
in
|
|
{
|
|
config = mkIf (config.rootfsType == "squashfs") {
|
|
system.outputs.rootfs = liminix.builders.squashfs config.filesystem.contents;
|
|
kernel.config = {
|
|
SQUASHFS = "y";
|
|
SQUASHFS_XZ = "y";
|
|
};
|
|
};
|
|
}
|