There is nothing in this commit except for the changes made by nix-shell -p nixfmt-rfc-style --run "nixfmt ." If this has mucked up your open branches then sorry about that. You can probably nixfmt them to match before merging
33 lines
552 B
Nix
33 lines
552 B
Nix
{
|
|
config,
|
|
pkgs,
|
|
lib,
|
|
...
|
|
}:
|
|
let
|
|
inherit (lib)
|
|
mkEnableOption
|
|
mkOption
|
|
mkIf
|
|
types
|
|
;
|
|
inherit (pkgs) runCommand;
|
|
in
|
|
{
|
|
options = {
|
|
system.outputs = {
|
|
systemConfiguration = mkOption {
|
|
type = types.package;
|
|
description = ''
|
|
pkgs.systemconfig for the configured filesystem,
|
|
contains 'activate' and 'init' commands
|
|
'';
|
|
internal = true;
|
|
};
|
|
};
|
|
};
|
|
config = {
|
|
system.outputs.systemConfiguration = pkgs.systemconfig config.filesystem.contents;
|
|
};
|
|
}
|