There is nothing in this commit except for the changes made by nix-shell -p nixfmt-rfc-style --run "nixfmt ." If this has mucked up your open branches then sorry about that. You can probably nixfmt them to match before merging
34 lines
622 B
Nix
34 lines
622 B
Nix
{
|
|
liminix,
|
|
lib,
|
|
json-to-fstree,
|
|
serviceFns,
|
|
}:
|
|
{
|
|
name,
|
|
url,
|
|
interval,
|
|
username,
|
|
password,
|
|
}:
|
|
let
|
|
inherit (liminix.services) oneshot longrun;
|
|
inherit (lib) optionalString;
|
|
in
|
|
longrun {
|
|
inherit name;
|
|
buildInputs = [ json-to-fstree ];
|
|
run = ''
|
|
${optionalString (username != null) ''
|
|
export NETRC=$(mkstate ${name})/netrc
|
|
(echo default ; echo login ${username} ; echo password ${password} ) > $NETRC
|
|
''}
|
|
( in_outputs ${name}
|
|
while : ; do
|
|
${json-to-fstree}/bin/json-to-fstree ${url} .
|
|
sleep ${builtins.toString (interval * 60)}
|
|
done
|
|
)
|
|
'';
|
|
}
|