1
0
liminix/pkgs/certifix-client/default.nix
Daniel Barlow 7e2b0068e6 nixfmt-rfc-style
There is nothing in this commit except for the changes made by
nix-shell -p nixfmt-rfc-style --run "nixfmt ."

If this has mucked up your open branches then sorry about that. You
can probably nixfmt them to match before merging
2025-02-10 21:55:08 +00:00

45 lines
606 B
Nix

{
fetchurl,
writeFennel,
fennel,
fennelrepl,
runCommand,
lua,
anoia,
lualinux,
fetch-freebsd,
openssl,
luaossl',
stdenv,
}:
let
name = "certifix-client";
in
stdenv.mkDerivation {
inherit name;
src = ./.;
buildInputs = [
fetch-freebsd
openssl
lua
];
buildPhase = "";
installPhase = ''
mkdir -p $out/bin
cp -p ${
writeFennel name {
packages = [
fetch-freebsd
fennel
anoia
lualinux
luaossl'
];
mainFunction = "run";
} ./${name}.fnl
} $out/bin/${name}
'';
}