1
0
liminix/pkgs/json-to-fstree/default.nix
Daniel Barlow 7e2b0068e6 nixfmt-rfc-style
There is nothing in this commit except for the changes made by
nix-shell -p nixfmt-rfc-style --run "nixfmt ."

If this has mucked up your open branches then sorry about that. You
can probably nixfmt them to match before merging
2025-02-10 21:55:08 +00:00

47 lines
632 B
Nix

{
fetchurl,
writeFennel,
fennel,
fennelrepl,
runCommand,
lua,
anoia,
linotify,
lualinux,
fetch-freebsd,
openssl,
rxi-json,
stdenv,
}:
let
name = "json-to-fstree";
in
stdenv.mkDerivation {
inherit name;
src = ./.;
buildInputs = [
fetch-freebsd
rxi-json
openssl
lua
];
buildPhase = "";
installPhase = ''
mkdir -p $out/bin
cp -p ${
writeFennel name {
packages = [
fetch-freebsd
rxi-json
anoia
lualinux
linotify
];
mainFunction = "run";
} ./${name}.fnl
} $out/bin/${name}
'';
}