There is nothing in this commit except for the changes made by nix-shell -p nixfmt-rfc-style --run "nixfmt ." If this has mucked up your open branches then sorry about that. You can probably nixfmt them to match before merging
45 lines
670 B
Nix
45 lines
670 B
Nix
{
|
|
fetchurl,
|
|
writeFennel,
|
|
fennel,
|
|
fennelrepl,
|
|
runCommand,
|
|
lua,
|
|
anoia,
|
|
linotify,
|
|
lualinux,
|
|
stdenv,
|
|
}:
|
|
let
|
|
name = "watch-ssh-keys";
|
|
in
|
|
stdenv.mkDerivation {
|
|
inherit name;
|
|
src = ./.;
|
|
|
|
buildInputs = [ lua ];
|
|
nativeBuildInputs = [ fennelrepl ];
|
|
|
|
buildPhase = ''
|
|
fennelrepl --test ./watch-ssh-keys.fnl
|
|
cp -p ${
|
|
writeFennel name {
|
|
packages = [
|
|
anoia
|
|
lualinux
|
|
linotify
|
|
fennel
|
|
];
|
|
macros = [
|
|
anoia.dev
|
|
];
|
|
mainFunction = "run";
|
|
} ./watch-ssh-keys.fnl
|
|
} ${name}
|
|
'';
|
|
|
|
installPhase = ''
|
|
install -D ${name} $out/bin/${name}
|
|
'';
|
|
}
|