You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
13 lines
448 B
13 lines
448 B
let
|
|
nixpkgs = <nixpkgs>;
|
|
liminix = (import ./default.nix {
|
|
device = (import ./devices/qemu);
|
|
liminix-config = ./vanilla-configuration.nix;
|
|
inherit nixpkgs;
|
|
});
|
|
in liminix.buildEnv.overrideAttrs (o: {
|
|
nativeBuildInputs = o.nativeBuildInputs ++ [ (import nixpkgs {}).sphinx ] ;
|
|
shellHook = ''
|
|
publish(){ make -C doc html && rsync -azv doc/_build/html/ myhtic.telent.net:/var/www/blogs/www.liminix.org/_site/doc; }
|
|
'';
|
|
})
|
|
|