1
0
liminix/pkgs/tufted/default.nix
Daniel Barlow 3df1ec76ff cleanup whitespace and commas
* [] is now [ ]
* {} is now { }
* commas in arglists go at end of line not beginning

In short, I ran the whole thing through nixfmt-rfc-style but only
accepted about 30% of its changes. I might grow accustomed to more
of it over time
2024-06-30 17:16:28 +01:00

31 lines
781 B
Nix

{
lua5_3,
stdenv,
makeWrapper,
}:
let
lua = lua5_3.withPackages (ps: with ps; [
luasocket luaposix fennel
]);
in stdenv.mkDerivation {
pname = "tufted";
version = "1";
phases = [ "unpackPhase" "installPhase" ];
buildInputs = [
lua
];
nativeBuildInputs = [ makeWrapper ];
src = ./.;
installPhase = ''
mkdir -p $out/lib
cp tftp.lua tufted.fnl $out/lib
makeWrapper ${lua.pkgs.fennel}/bin/fennel \
$out/bin/tufted \
--prefix LUA_CPATH \; "${lua}/lib/lua/5.3/?.so" \
--add-flags "--add-fennel-path $out/lib/?.fnl" \
--add-flags "--add-package-path $out/lib/?.lua" \
--add-flags "--add-package-path ${lua}/share/lua/5.3/?.lua\;${lua}/share/lua/5.3/?/init.lua" \
--add-flags "$out/lib/tufted.fnl"
'';
}