forked from dan/liminix
* [] is now [ ] * {} is now { } * commas in arglists go at end of line not beginning In short, I ran the whole thing through nixfmt-rfc-style but only accepted about 30% of its changes. I might grow accustomed to more of it over time
20 lines
451 B
Nix
20 lines
451 B
Nix
{
|
|
stdenv,
|
|
lua,
|
|
fetchFromSourcehut,
|
|
}:
|
|
let pname = "fennel";
|
|
in stdenv.mkDerivation {
|
|
inherit pname;
|
|
version = "1.3";
|
|
nativeBuildInputs = [ lua ]; # used in build
|
|
buildInputs = [ lua ]; # needed for patchShebangs
|
|
src = fetchFromSourcehut {
|
|
owner = "~technomancy";
|
|
repo = pname;
|
|
rev = "1.3.0";
|
|
hash = "sha256-DXJOdYzfjTncqL7BsDbdvZcauDMkZV2X0U0FfhfwQrw=";
|
|
};
|
|
makeFlags = [ "PREFIX=${placeholder "out"}" ];
|
|
}
|