forked from dan/liminix
* I didn't know what I was doing when I set up Hydra * it's not certain that I do now either, but hey ho
16 lines
389 B
Nix
16 lines
389 B
Nix
let img = (import <liminix> {
|
|
device = import <liminix/devices/qemu>;
|
|
liminix-config = ./configuration.nix;
|
|
}).outputs.vmroot;
|
|
pkgs = import <nixpkgs> { overlays = [(import ../../overlay.nix)]; };
|
|
in pkgs.runCommand "check" {
|
|
nativeBuildInputs = with pkgs; [
|
|
expect
|
|
socat
|
|
] ;
|
|
} ''
|
|
mkdir vm
|
|
${img}/run.sh --background ./vm
|
|
expect ${./script.expect} >$out
|
|
''
|