There is nothing in this commit except for the changes made by nix-shell -p nixfmt-rfc-style --run "nixfmt ." If this has mucked up your open branches then sorry about that. You can probably nixfmt them to match before merging
22 lines
313 B
Nix
22 lines
313 B
Nix
{
|
|
config,
|
|
lib,
|
|
pkgs,
|
|
...
|
|
}:
|
|
let
|
|
inherit (pkgs.liminix.services) longrun;
|
|
in
|
|
{
|
|
config.services.klogd = longrun {
|
|
name = "klogd";
|
|
run = ''
|
|
echo "1 2 1 8" > /proc/sys/kernel/printk
|
|
cat /proc/kmsg
|
|
'';
|
|
finish = ''
|
|
echo "8 4 1 8" > /proc/sys/kernel/printk
|
|
'';
|
|
};
|
|
}
|