There is nothing in this commit except for the changes made by nix-shell -p nixfmt-rfc-style --run "nixfmt ." If this has mucked up your open branches then sorry about that. You can probably nixfmt them to match before merging
26 lines
393 B
Nix
26 lines
393 B
Nix
{ config, lib, ... }:
|
|
let
|
|
inherit (lib)
|
|
mkIf
|
|
mkEnableOption
|
|
mkOption
|
|
types
|
|
;
|
|
in
|
|
{
|
|
options = {
|
|
logging = {
|
|
persistent = {
|
|
enable = mkEnableOption "store logs across reboots";
|
|
};
|
|
};
|
|
};
|
|
config = {
|
|
kernel.config = mkIf config.logging.persistent.enable {
|
|
PSTORE = "y";
|
|
PSTORE_PMSG = "y";
|
|
PSTORE_RAM = "y";
|
|
};
|
|
};
|
|
}
|