There is nothing in this commit except for the changes made by nix-shell -p nixfmt-rfc-style --run "nixfmt ." If this has mucked up your open branches then sorry about that. You can probably nixfmt them to match before merging
13 lines
238 B
Nix
13 lines
238 B
Nix
{
|
|
lib,
|
|
writeText,
|
|
}:
|
|
name: config:
|
|
writeText name (
|
|
builtins.concatStringsSep "\n" (
|
|
lib.mapAttrsToList (
|
|
name: value: (if value == "n" then "# CONFIG_${name} is not set" else "CONFIG_${name}=${value}")
|
|
) config
|
|
)
|
|
)
|