1
0
liminix/pkgs/kernel/write-kconfig.nix
Daniel Barlow 7e2b0068e6 nixfmt-rfc-style
There is nothing in this commit except for the changes made by
nix-shell -p nixfmt-rfc-style --run "nixfmt ."

If this has mucked up your open branches then sorry about that. You
can probably nixfmt them to match before merging
2025-02-10 21:55:08 +00:00

13 lines
238 B
Nix

{
lib,
writeText,
}:
name: config:
writeText name (
builtins.concatStringsSep "\n" (
lib.mapAttrsToList (
name: value: (if value == "n" then "# CONFIG_${name} is not set" else "CONFIG_${name}=${value}")
) config
)
)