1
0
liminix/pkgs/write-ash-script/bin.nix
Daniel Barlow 7e2b0068e6 nixfmt-rfc-style
There is nothing in this commit except for the changes made by
nix-shell -p nixfmt-rfc-style --run "nixfmt ."

If this has mucked up your open branches then sorry about that. You
can probably nixfmt them to match before merging
2025-02-10 21:55:08 +00:00

19 lines
226 B
Nix

{
writeScriptBin,
lib,
}:
name:
{
runtimeInputs ? [ ],
}:
text:
writeScriptBin name ''
#!/bin/sh
set -o errexit
set -o nounset
set -o pipefail
export PATH="${lib.makeBinPath runtimeInputs}:$PATH"
${text}
''