forked from dan/liminix
* [] is now [ ] * {} is now { } * commas in arglists go at end of line not beginning In short, I ran the whole thing through nixfmt-rfc-style but only accepted about 30% of its changes. I might grow accustomed to more of it over time
28 lines
537 B
Nix
28 lines
537 B
Nix
{
|
|
nellie,
|
|
lualinux,
|
|
writeFennel,
|
|
anoia,
|
|
fennel,
|
|
stdenv,
|
|
fennelrepl,
|
|
s6-rc-up-tree,
|
|
}:
|
|
stdenv.mkDerivation {
|
|
name = "uevent-watch";
|
|
src = ./.;
|
|
nativeBuildInputs = [ fennelrepl ];
|
|
propagatedBuildInputs = [ s6-rc-up-tree ];
|
|
installPhase = ''
|
|
mkdir -p $out/bin
|
|
cp -p ${writeFennel "uevent-watch" {
|
|
packages = [fennel anoia nellie lualinux s6-rc-up-tree] ;
|
|
mainFunction = "run";
|
|
} ./watch.fnl} $out/bin/uevent-watch
|
|
'';
|
|
checkPhase = ''
|
|
fennelrepl ./test.fnl
|
|
'';
|
|
doCheck = true;
|
|
}
|